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Exercise 1 – Convert C to F

Build a VI
Complete the following steps to create a VI that takes a number representing
degrees Celsius and converts it to a number representing degrees Fahrenheit.
If the Tools or Controls palette isn’t visible when the front panel is active select
View»Tools (or Controls) Palette. Similar applies for the Functions palette
when viewing the diagram.

Front Panel
1. Select Blank VI to open a new front panel.
2. (Optional) Select Window»Tile Left and Right to display the front
panel and block diagram side by side.
3. Create a numeric digital control. You will use this control to enter the
value for degrees Centigrade.
Select the numeric control on the Modern»Numeric palette. Move
the control to the front panel and click to place the control.
a. Type deg C inside the label and click outside the label or click
the Enter button on the toolbar. If you do not type the name
immediately, LabVIEW uses a default label. You can edit a label
at any time by using the Labeling tool.
4. Create a numeric digital indicator. You will use this indicator to display
the value for degrees Fahrenheit.
a. Select the numeric indicator on the Modern»Numeric palette.
b. Move the indicator to the front panel and click to place the
indicator.
c. Type deg F inside the label and click outside the label or click
the Enter button.
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LabVIEW creates corresponding control and indicator terminals on the
block diagram. The terminals represent the data type of the control or
indicator. For example, a DBL terminal represents a double-precision
floating-point numeric control or indicator.
Note Control terminals have a thicker border than indicator terminals.

Block Diagram
5. Display the block diagram by clicking it or by selecting Window»Show
Diagram.

Note: Block Diagram terminals can be viewed as icons or as terminals.
To change the way LabVIEW displays these objects right click on a
terminal and select View as Icon.

6. Select the Multiply and Add functions on the Programming»Numeric
palette and place them on the block diagram. If the Functions palette
is not visible, right-click an open area on the block diagram to display
it.
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7. Select the numeric constant on the Programming»Numeric palette
and place two of them on the block diagram. When you first place the
numeric constant, it is highlighted so you can type a value.
8. Type 1.8 in one constant and 32.0 in the other.
If you moved the constants before you typed a value, use the Labeling
tool to enter the values.
9. Use the Wiring tool to wire the icons as shown in the previous block
diagram.


To wire from one terminal to another, use the Wiring tool to click
the first terminal, move the tool to the second terminal, and click
the second terminal, as shown in the following illustration. You
can start wiring at either terminal.



You can bend a wire by clicking to tack the wire down and
moving the cursor in a perpendicular direction. Press the
spacebar to toggle the wire direction.



To identify terminals on the nodes, right-click the Multiply and
Add functions and select Visible Items»Terminals from the
shortcut menu to display the connector pane. Return to the
icons after wiring by right-clicking the functions and selecting
Visible Items»Terminals from the shortcut menu to remove the
checkmark.



When you move the Wiring tool over a terminal, the terminal
area blinks, indicating that clicking will connect the wire to that
terminal and a tip strip appears, listing the name of the terminal.

PH2150 G Boorman 2011



To cancel a wire you started, press the <Esc> key, right-click, or
click the source terminal.

10. Display the front panel by clicking it or by selecting Window»Show
Front Panel.(or use ctrl-E to switch between the front pane and the
diagram)
11. Save the VI because you will use this VI later in the course.
a. Select File»Save.
b. Navigate to your home directory and create a folder to store the
Vis you create.
Note Save all the VIs you edit in this course to your directory.

c. Type Convert C to F.vi in the dialog box.
d. Click the Save button.
12. Enter a number in the digital control and run the VI.
a. Use the Operating tool or the Labeling tool to double-click the
digital control and type a new number.
b. Click the Run button to run the VI.
c. Try several different numbers and run the VI again.
13. Select File»Close to close the Convert C to F VI.

End of Exercise
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Exercise 2 – Create a SubVI
Front Panel
1. Select File»Open and open the VI Convert C to F.vi.
If you closed all open VIs, click the Open… button on the LabVIEW
dialog box.
Tip Click the arrow next to Open… button on the LabVIEW dialog box to open

recently opened files, such as Convert C to F.vi.
The following front panel appears.

2. Right-click the icon in the upper right corner of the front panel and
select Edit Icon from the shortcut menu. The Icon Editor dialog box
appears.
3. Select Edit»Clear All to remove the existing icon.
4. Double-click the Rectangle tool to redraw the border.

5. Create the following icon.
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a. Use the Text tool (T) and click on the edit area.
b. Type ‘C’ and ‘F’.
c. Use the Pencil tool to create the arrow.
Note To draw horizontal or vertical straight lines, press the <Shift> key

while you use the Pencil tool to drag the cursor.
d. Use the Select tool and the arrow keys to move the text and
arrow you created.
e. When the icon is complete, click the OK button to close the Icon
Editor dialog box. The icon appears in the upper right corner of
the front panel and block diagram.
6. Right-click the icon on the front panel and select Show Connector
from the shortcut menu to define the connector pane terminal pattern.
By default, LabVIEW will present the standard twelve-terminal pattern,
but only two terminals are used in this VI. Right-click the connector
pane and select Patterns and choose the fourth pattern on the top
row.

7. Assign the terminals to the digital control and digital indicator.
a. Click the left terminal in the connector pane. The tool
automatically changes to the Wiring tool, and the terminal turns
black.
b. Click the deg C control. The left terminal turns orange, and a
marquee highlights the control.
c. Click an open area of the front panel. The marquee disappears,
and the terminal changes to the data type color of the control to
indicate that you connected the terminal.
d. Click the right terminal in the connector pane and click the deg
F indicator. The right terminal turns orange.
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e. Click an open area on the front panel. Both terminals are
orange.
f. Move the cursor over the connector pane. The Context Help
window shows that both terminals are connected to floatingpoint values.
8. Select File»Save to save the VI because you will use this VI later in
the course.
9. Select File»Close to close the Convert C to F VI.

End of Exercise
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Exercise 3 – Simulated Data Acquisition
To complete this exercise, you will need to use the VI thermo_input.vi. This can
be copied from the PH2150 web page and saved in your Labview directory.

Front Panel
1. Select File»New to open a new front panel.
2. Create the thermometer indicator, as shown on the following front
panel.

a. Select the thermometer on the Modern»Numeric palette and
place it on the front panel.
b. Type Temperature inside the label and click outside the label or
click the Enter button on the toolbar.
c. Right-click the thermometer and select Visible Items»Digital
Display from the shortcut menu to display the digital display for
the thermometer.
3. Create the vertical switch control.
a. Select the vertical toggle switch on the Modern»Boolean
palette.
b. Type Temp Scale inside the label and then click outside the label
or click the Enter button.
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c. Use the Labeling tool to place a free label, deg C, next to the
TRUE position of the switch, as shown in the previous front
panel (or double click front panel empty space).
d. Place a free label, deg F, next to the FALSE position of the
switch.

Block Diagram
4. Select Window»Show Block Diagram to display the block diagram.
5. Build the following block diagram.

a. Select the function palette Select a VI… and navigate to the
Thermometer Sim.vi that was downloaded from the web page. This
VI generates some simulated temperature data.
b. Place the multiply function located on the Programming»Numeric
palette. This will scale the output from Thermo Input to Celsius.
c. Select Select a VI… and navigate to the Convert C to F VI, which
you built in Exercise 2, and place the VI on the block diagram. This
VI converts the Celsius value to Fahrenheit.
d. Place the Select function located on the
Programming»Comparison palette. This function returns either
the Fahrenheit (FALSE) or Celsius (TRUE) temperature value,
depending on the position of Temp Scale switch.
e. Right-click the y terminal of the Multiply function, select
Create»Constant, type 100, and press the <Enter> key to create
the constant.
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f. Use the Positioning tool to place the icons as shown in the previous
block diagram and use the Wiring tool to wire them together.
6. Display the front panel by clicking it or by selecting Window»Show
Front Panel.
7. Click the Continuous Run button, shown at left, to run the VI
continuously.
8. Click the Continuous Run (or the red Stop) button again to stop the
VI.
9. Create the following icon, so you can use the Temperature VI as a
sub-VI.

Right-click the icon in the upper right corner of the front panel and
select Edit Icon from the shortcut menu. The Icon Editor dialog box
appears.
10. Select Edit»Clear All to remove the existing icon. Double-click the
Rectangle tool to redraw the border. Use the Pencil tool to draw an
icon that represents the thermometer. Use the Foreground and Fill
tools to color the thermometer red.
Note To draw horizontal or vertical straight lines, press the <Shift> key while you

use the Pencil tool to drag the cursor.
a. Double-click the Text tool, shown at left, and change the font to
Small Fonts and ensure font size is 11.
b. When the icon is complete, click the OK button. The icon appears
in the upper right corner of the front panel.
11. Assign terminals to the Temperature display and C/F switch. Use a
two-terminal connector as in the previous exercise. Right click on the icon
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and show connector. Wire the right-hand terminal to Temperature and the
left-hand terminal to the switch.
12. Select File»Save and save the VI as Thermometer.vi.
13. Select File»Close to close the VI.

End of Exercise
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Exercise 4 – Using Loops

Use a while loop and a waveform chart to build a VI that demonstrates software
timing.

Front Panel
1. Open a new VI.
2. Build the following front panel.

a. Select the Horizontal Pointer Slide on the Modern»Numeric palette
and place it on the front panel. You will use the slide to change the
software timing.
b. Type millisecond delay inside the label and click outside the label or
click the Enter button on the toolbar, shown at left.
c. Place a Stop Button from the Modern»Boolean palette.
d. Select a Waveform Chart on the Modern»Graph Indicators palette
and place it on the front panel. The waveform chart will display the
data in real time.
e. Type Value History inside the label and click outside the label or click
the Enter button.
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f. The waveform chart legend labels the plot Plot 0. Use the Labeling
tool to triple-click Plot 0 in the chart legend, type Value, and click
outside the label or click the Enter button to re-label the legend.
g. The random number generator generates numbers between 0 and
1, in a classroom setting you could replace this with a data
acquisition VI. Use the Labeling tool to double-click 10.0 in the yaxis, type 1, and click outside the label or click the Enter button to
rescale the chart.
h. Change –10.0 in the y-axis to 0.
i.

Label the y-axis Value and the x-axis Time (sec).

Block Diagram
3. Select Window»Show Block Diagram to display the block diagram.

4. Enclose the two terminals in a While Loop, as shown in the following
block diagram.

a. Select the While Loop on the Programming»Structures
palette.
b. Click and drag a selection rectangle around the two terminals.
c. Use the Positioning tool to resize the loop, if necessary.

PH2150 G Boorman 2011

5. Select the Random Number (0-1) on the Programming»Numeric
palette. Alternatively you could use a VI that is collecting data from an
external sensor.
6. Wire the block diagram objects as shown in the previous block
diagram.
7. Save the VI as Use a Loop.vi because you will use this VI later in the
course.
8. Display the front panel by clicking it or by selecting Window»Show
Front Panel.
9. Run the VI.
The section of the block diagram within the While Loop border
executes until the specified condition is TRUE. For example, while the
STOP button is not pressed, the VI returns a new number and displays
it on the waveform chart.
10. Click the STOP button to stop the acquisition. The condition is now
TRUE, and the loop stops executing.
11. Format and customize the X and Y scales of the waveform chart.
a. Right-click the chart and select Properties from the shortcut
menu. The following dialog box appears.
b. Click the Scale tab and select different styles for the y-axis. You
also can select different mapping modes, grid options, scaling
factors, and formats and precisions. Notice that these will
update interactively on the waveform chart
c. Select the options you desire and click the OK button.
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12. Right-click the waveform chart and select Data Operations»Clear
Chart from the shortcut menu to clear the display buffer and reset the
waveform chart. If the VI is running, you can select Clear Chart from
the shortcut menu.

Adding Timing
When this VI runs, the While Loop executes as quickly as possible. Complete the
following steps to take data at certain intervals, such as once every half-second,
as shown in the following block diagram.
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a. Add the wait (ms) located on the Programming»Timing palette
to your VI
b. This will allow you to adjust the speed of the execution from the
pointer slide on the front panel.
13. Save the VI as Thermometer Chart.vi, because you will use this VI
later in the course.
14. Run the VI.
15. Try different values for the second delay and run the VI again. Notice
how this affects the speed of the number generation and display.
16. Close the VI.

End of Exercise
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Exercise 5 - Analyzing and Logging Data
Complete the following steps to build a VI that measures temperature every
0.25s for 10s. During the acquisition, the VI displays the measurements in real
time on a waveform chart. After the acquisition is complete, the VI plots the data
on a graph and calculates the minimum, maximum, and average temperatures.
The VI displays the best fit of the temperature graph.

Front Panel
1. Open a new VI and build the following front panel using the following
tips.



Do not create the Mean, Max, and Min indicators yet.
Create them on the Block Diagram by right clicking on the
functions and choosing Create Indicator. Then position them
on the Front Panel.



Add the Digital Display to the thermometer as in Exercise 3.



Right-click Current Data Point and change representation to
I32.
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Block Diagram

2. Build the following block diagram.

a. Select Select a VI… and choose Thermometer.vi (from exercise
3).
b. Place the Wait Until Next ms Multiple function located on the
Programming»Timing palette and create a constant of 250.
This causes the For Loop to execute every 0.25s (250ms).
c. IMPORTANT: Ensure the output tunnel from the While loop
generates an array: right click the tunnel and select enable
indexing.
d. Place the Array Max & Min function located on the
Programming»Array palette. This function returns the
maximum and minimum temperature.
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e. Place the Mean VI located on the Mathematics»Probability
and Statistics palette. This VI returns the average of the
temperature measurements.
f. Right-click the output terminals of the Array Max & Min function
and Mean VI and select Create»Indicator from the shortcut
menu to create the Max, Min, and Mean indicators.
g. Place the Write to Spreadsheet File located on the File I/O
palette. Connect the temperature data to the 1D data input.

3. Save the VI as Temperature Logger.vi.
4. Display the front panel and run the VI.
5. After pressing STOP a dialog box will appear. Enter the name of the
file to save the spreadsheet, with the extension .txt
6. Check the data-file contains valid data by opening it in Excel or a text
editor such as Notepad.

End of Exercise
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